Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
72:system_requirements [2019/04/26 07:43]
etea [System Integrations]
72:system_requirements [2019/07/18 08:48] (current)
Ralf Poehlmann [Client Requirements]
Line 10: Line 10:
 |Microsoft Edge|Latest Version| |Microsoft Edge|Latest Version|
 |Mozilla Firefox|Latest Version| |Mozilla Firefox|Latest Version|
 +|Mobile Safari|Latest Version|
  
 //Note: The browser must have cookies and JavaScript enabled. // //Note: The browser must have cookies and JavaScript enabled. //
 +
 +\\
 +
 +
 ===== Server Requirements ===== ===== Server Requirements =====
  
 Stages is a Java application and is executed on a Tomcat application server. The application server is automatically installed together with Stages. Stages is a Java application and is executed on a Tomcat application server. The application server is automatically installed together with Stages.
  
-The application server also acts as a web server. Thus, no additional web server (i.e. Apache or IIS) is required.+The application server also acts as a web server. Thus, no additional web server (i.e. Apache or IIS) is required.But if you do deploy Stages behind a web server (i.e. Apache or IIS), please ensure that: 
 + 
 +  * the https and wss (web socket) protocol URLs are forwarded for /stages and below. 
 +  * the https protocol URLs are forwarded for /reporting and below. 
 +  * the https protocol URLs are forwarded for /pkit and below, if you want the V6 Stages Bookmarks to be redirected to their V7 counterparts.
  
 When using configuration management system integration (e.g. IBM Rational ClearCase, CVS), a client installation of the respective configuration management system is required on the server. When using configuration management system integration (e.g. IBM Rational ClearCase, CVS), a client installation of the respective configuration management system is required on the server.
Line 26: Line 35:
 ^Software Requirements^Description| ^Software Requirements^Description|
 |Operating System| \\ Windows Server 2003 (64-Bit) \\ Windows Server 2008 (64-Bit) \\ Windows Server 2012 (64-Bit) \\ Windows Server 2016 (64-Bit) \\ Windows 7 (64-Bit) \\ Windows 10 (64-Bit) \\ Linux (64-Bit) with RPM and LSB \\   \\ Support for other operating systems (e.g. Solaris) is available upon request.| |Operating System| \\ Windows Server 2003 (64-Bit) \\ Windows Server 2008 (64-Bit) \\ Windows Server 2012 (64-Bit) \\ Windows Server 2016 (64-Bit) \\ Windows 7 (64-Bit) \\ Windows 10 (64-Bit) \\ Linux (64-Bit) with RPM and LSB \\   \\ Support for other operating systems (e.g. Solaris) is available upon request.|
-|Java Virtual Machine|Java SE Development Kit 1.8.0_1 or any higher 1.8.x version (64-Bit)|+|Java Virtual Machine|Java SE Development Kit 1.8.0_1 or any higher 1.8.x version (64-Bit) (Oracle, AdoptOpenJDK,​ OpenJDK)| 
 + 
 +\\ 
  
 ===== Database Requirements ===== ===== Database Requirements =====